OpenRoads Designer CONNECT Edition SDK Help

ILinearClosed Interface

Defines methods for all closed linear elements

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public interface ILinearClosed

Properties

IsClockWise Gets whether the element is defined in clockwise direction.

Methods

GetBestApproximatedArea(Double) Gets the area of a linear closed element (closed line string or closed complex);
GetBestApproximatedArea(Double, Double) Gets the area of a linear closed element (closed line string or closed complex);

See Also